After Effects & Premiere Pro Plugin

Help > After Effects & Premiere Pro Plugin

System Requirements:

OSX
  • OSX 10.9.5 or above is required.
  • Adobe After Effects or Premiere Pro CC 2015 or later
  • For OpenCL rendering a version 1.1 capable graphics card and runtime system are required.
  • For CUDA rendering a CUDA Compute Compatibility version 3.0 capable graphics card is required.
Windows
  • Adobe After Effects or Premiere Pro CC 2015 or later.
  • Windows 7 sp1 (64 bit) and up.
  • For OpenCL rendering an OpenCL 1.1 capable graphics card and runtime system are required.
  • For CUDA rendering a CUDA Compute Compatibility version 3.0 capable graphics card is required.
Steps for installing FilmConvert:
  • Download the latest FilmConvert After Effects Plugin installer for your desired operating system.
  • Once complete, go to your downloads folder.
    • Windows:
      • Double click the installer to execute it.
    • Mac:
      • Double click the DMG to open it.
      • Inside is an executable file. Double click it to start the installation.
    • Follow the instructions given by the installer.

Once complete, the plugin resides in the following directories:
  • OS X
    • /Library/Application Support/Adobe/Common/Plug-ins/$version/MediaCore/FilmConvertPro2.1.plugin
    • /Library/Application Support/RubberMonkey
  • Windows
    • C:\Program Files\Adobe\Common\Plug-ins\$version\MediaCore\FilmConvertPro2.1.aex
    • C:\ProgramData\RubberMonkey
Once FilmConvert is installed, you will want to apply it to your footage. To do that:
  • First open up After Effects or Premiere.
  • Create a new project, or open up an existing project.
  • In the case of a new project, import some media, and drag it onto the timeline (Premiere) or a composition (After Effects).
  • If in Premiere find the Effects tab. In After Effects, find the Effects menu item.
  • Go the Film Emulation category, which currently has just one item FilmConvert. Drag the effect onto your media.

You will now see some color changes, grain and FilmConvert water marks on your media!

NOTE: If the Film Emulation category is not visible in Premiere, close Premiere, then re-launch with the Shift and Alt keys held down until the welcome screen appears. This will clear the plugin cache.

If the Effect is still not present, Windows users should download and install recent graphics drivers (for a working OpenCL runtime), then clear the plugin cache again.
  • Source Camera Selects the camera (or camera type) used to shoot your footage. This setting is required in order to apply the correct color correction.
  • Exposure Performs an adjustment prior to the film emulation being applied.
  • Temp Adjusts the color temperature. This assumes that the clip temp is 5600 (daylight). Moving the slider to the left makes the scene cooler. Moving to the right makes it warmer.

Note for RED footage. You should apply our metadata preset in the Adobe provided Source Settings interface. This preset merely resets all metadata settings to their default, thereby giving FilmConvert a known starting point for color adjustments.
  • Convert To drop down Selects the particular film stock to be emulated.
  • Size drop down Selects the negative size to emulate. Smaller values such as 8mm are fuzzier with larger grain. Larger values have smaller grain.
  • Film Color slider Adjusts the balance between the original digital camera color palette, and the film color palette. Typically you would leave this at 100% film
  • Curve slider This control allows you to reduce changes in luminosity, so that the original exposure of the digital footage is preserved. Setting the slider to 0 with the color slider at 100 will give you the hue and saturation of the film stock, with no change to the luminosity.
  • Grain slider Adjusts the amount of grain applied to the image. The default is 100%, which is an accurate representation of the grain for the selected film stocks. Some stocks have more grain - such as D3200.

Color Corrector Section

  • Shadows, midtones, and highlights This is a standard color corrector, any adjustments made will affect the image in the following ways:
    Shadows - adjustments will affect pure black 100%, mid grey at 50%, and pure white at 0%.
    Midtones - adjustments affect pure black 0%, mid grey 100%, and pure white 0%
    Highlights - adjustments affect pure black 0%, mid grey 50%, and pure white 100%
  • Color wheels The 3 wheels adjust the color of the shadows, midtones, and highlights. Drag the white knob around the circle to add color.
  • Sliders The sliders adjust the image by adding or removing brightness in the manner described above. Adjustments happen before the color wheel adjustment - so you can use these sliders to control how much of the image is in the upper highlight area before applying the color cast to it.
  • Saturation slider will saturate or de-saturate the image.

Levels Graph

  • Graph shows the relative amount of luminosity in each color band. Dark images will show larger values on the left side of the graph, bright images on the right side.
  • Clipping indicators To the left and the right of the graph, these bars show up when you have pure black or pure white in your image.
  • Black, mid, white sliders Use these to set the clipping point for black and white, and where the mid point grey lies
Once you have purchased FilmConvert, you will be emailed a license file in the form of an FKV file.

In order to use the FKV file:
  • Download and install the Trial version of the After Effects plugin.
  • Start After Effects or Premiere.
  • Apply the FilmConvert effect to some media in order to get access to the FilmConvert controls. For instructions on how to do that, see Applying FilmConvert to your media.
  • Once you have access to the FilmConvert controls, find the Register Plugin control, which has a single button labelled Open License File.
  • Once pressed, you will be presented with a new Window, FilmConvert Product Registration.
  • Hit the Load License File button and browse to your FKV file.
  • Open it, and your plugin will be registered!
To uninstall the FilmConvert After Effects plugin from a Windows machine, simply use the Control Panel.


To uninstall the FilmConvert After Effects plugin from a Mac, delete:
  • /Library/Application Support/Adobe/Common/Plug-ins/$version/MediaCore/FilmConvertPro2.1.plugin
Where $version should be substituted for each version of CS or CC you have installed.


If you are deleting all FilmConvert plugins and the Stand-Alone application, you will also need to delete:
  • /Library/Application Support/RubberMonkey